プチメモ

2.7 で変わったもの

        

Render Performance の Cache BVH オプションがなくなった (2.77)

BVH の構築に時間のかかるレンダリングをテストレンダリング等で頻繁に行うときや、オブジェクトに変更なくカメラの移動等だけのアニメーションのレンダリングの場合にはとても有効だったと思うのですが、このオプションが消えてしまいました。
BVH のキャッシュができた方がレンダリングのトータル時間が縮まる場合は、2.77 より前のバージョンで処理することを考えても良いかもしれません。

レンダリング残り時間の表示 (2.70)

レンダリング時に UV/Image Editor のビュー上部に、以下の様に Remaining として残り時間が表示されるようになった。
Frame:1 | Last:03:06.25 Time:00:10.88 | Remaining:04:49.99 | Mem:0.44M, Peak:0.44M | Scene, RenderLayer | Path Tracing Tile 100/2500

レンダリング時のプログレッシブバーがパーセント表示 (2.77)

レンダリング時に表示されるプログレッシブバーにパーセント表示が追加されました。
headerInfo_277.png

パイメニュー

対応するキーを押したときにカーソル周辺にぐるっとメニューを表示するパイメニューを表示することも可能になった。
File > User Preferences で Add-ons から User Interface: Pie Menus Official を有効にする (pie と検索すると早いです) と使えるようになる。初期値では以下のパイメニューが設定されています。
  • Tab : インタラクションモード
  • Z : ビューポートシェーディングと Smooth/Flat シェーディング
  • Q : ビュー方向とパースあり/なし、4 分割ビュー切替
  • ShiftCtrlTab : スナッピング
  • . : ピボット
  • CtrlSpace : マニピュレータ
で、メニューも変更できるそうです。
でも、今までの UI で慣れちゃってるから、クイック感がなくなってしまうので、この設定はパス。。。

レンダリングスロット名の変更 (2.73)

レンダリングスロットの名前を変更できるようになった。
Render Result で Properties N を表示し、Display - Slot Name にスロット名を入力。

Render Result から部分レンダリング範囲を指定 (2.73)

Render Result でCtrlB でレンダリング範囲を指定することで、Border レンダリングの範囲を指定することができるようになった。

ノードエディタのスナップツール (2.75)

ノードエディタのヘッダに、スナップが追加された
スナップをオンにする (ShiftTab でオンオフ切替) と、ノード移動時にグリッドや他のノードにスナップさせながら移動することができる。
スナップの対象は、スナップアイコンの右隣 (ShiftCtrlTab で切替) で切り替えられる。

シーン全体のシンプリファイを設定 (2.75)

オブジェクトに対して Subsurf Modifier を追加すると、そのオブジェクトの 3D View 上の細かさと実際にレンダリングした時の細かさを、Subdivisions で設定することができるが、これをシーン全体に対して設定することができるようになった。
Scene - Simplify オプションを有効にし、Viewport, Render それぞれの Subdivision を設定することができる。
個々のオブジェクトの Modifier で、ここで設定した値以上のものがあっても、ここの値が上限値となる。

レンダリングパスの表示切替 (2.75)

Render Result で、Select Pass の右隣に、Previous PassNext Pass が追加され、ここを押すことでレンダリングパスを切り替えることができるようになった。


その他

        

シーンを超えてオブジェクトをリンク

  1. 持ってきたいオブジェクトがあるシーンに切り替え、持ってきたいオブジェクトを選択し、
  2. Object - Make Links - Object to Scene - 持って行く先のシーンを選択

シーンの追加方法

  1. シーン名右横の「+」をクリック
  2. New Scene から追加方法を選択
    • New
      • 空のシーンが作成される
      • レンダリング設定はデフォルトになる
    • Copy Settings
      • カラのシーンが作成される
      • レンダリング設定はコピーされる
    • Link Objects
      • シーン追加実行時のシーンと同じコンテンツを持つ新しいシーンが作成される
      • 実体としてはコピーされず、元のシーンの「オブジェクト」へのリンクが含まれる
      • 新しいシーンでの変更はコピー元のシーンにも反映される
    • Link Object Data
      • シーン追加実行時のシーンと同じコンテンツを持つ新しいシーンが作成される
      • 実体として「オブジェクト」がコピーされる
      • コピーされたオブジェクトは元のシーンのオブジェクトと同じ「オブジェクトデータ」へのリンクが含まれる
      • 新しいシーンでの「オブジェクト」の位置や向きといった変更は、コピー元のシーンに影響を与えない
      • 新しいシーンでのメッシュやマテリアルといった「オブジェクトデータ」への変更はコピー元のシーンにも反映される
    • Full Copy
      • シーン追加実行時のシーンと同じコンテンツを持つ新しいシーンが作成される
      • 「オブジェクト」も「オブジェクトデータ」もすべてコピーされる
      • コピー元のシーンとの関連はないので、コピー先での変更はコピー元には影響を与えない


あるSceneにいろいろ作ったが、カメラやワールド毎にSceneを分けたくなった時
元Sceneで、Link Objects でSceneを追加
追加されたSceneで必要なオブジェクト以外を削除 (ここで削除しても、元Sceneには残ってる)
元Sceneに戻ると、追加されたSceneにリンクされているオブジェクトは青いマーカーが付いている
他Sceneにオリジナルを移したいオブジェクトを選択して Object - Make Single User - Object を実行し、Selected Objects を選択
元シーンにあったリンクオブジェクトが複製されたオブジェクトとなり、追加されたSceneにあるリンクオブジェクトがオリジナルオブジェクトとなる
元シーンにある複製されたオブジェクトを削除する
これで、追加されたSceneに必要なオブジェクトがオリジナルとして移動したことになる


リンクオブジェクトのマテリアルを変えたい時

Material パレットの「Link material to object or the object's data」を「Data」→「Object」にする
これはマテリアルスロット毎に可能なので、マテリアルリスト内の一部のマテリアルのみを変えることも可能


F-Curve のハンドルタイプの変更

  • 変更するハンドルをRMBで選択
  • V
  • Set Keyframe Handle Type を選択
    • Free
    • Vector
    • Aligned
    • Automatic
    • Auto Clamped

オブジェクトを曲線上に動かす

  • カーブを作成
  • オブジェクトに Object constraints の Follow Path を割り当てる
  • Follow Path の Target に作成したカーブを指定
  • Follow Curve と Fixed Position を On にする
  • Forwerd と Up でオブジェクトの向きを制御
  • あとは Offset の値を変更すると、カーブのそのパラメータ位置にオブジェクトが来る

オブジェクトを落とす

  • 落とすオブジェクトへの設定
    • 落とすオブジェクトを選択
    • Physics - Rigid Body
      • これだけで落ちる
      • CtrlAで確かめられる
  • 落とす先に床への設定
    • 床とするオブジェクトを選択
    • Physics - Rigid Body
    • Rigid Body の Type を Passive に変更
      • これで床は落ちなくなり、床の上にオブジェクトが落ちると止まる
  • 落ちたオブジェクトがバウンドするには
    • 落ちるオブジェクトと床オブジェクト共に Physics - Rigid Body Collisions の Bounciness を上げる
      • どちらかのオブジェクトの Bounciness の値が 0 だとはねない

選択されているイメージファイルをハイライト表示させる

Image TextureEnvironment Texture で 既にファイルが指定されている状態で Open image を実行すると、ファイルを選択するウィンドウで現在指定されているファイル名が表示される
しかし、そのファイルがどれなのか、ファイルのリストではぱっと見分からない
そこで、ファイルリストの中のどれが現在設定されているファイルなのかをハイライト表示させる方法
  1. まず、現在指定されているファイル名のあるフィールドを一度クリックし、そこをアクティブにする
  2. 次に、ファイルリスト内のファイルの無いところをクリックし、ファイルリストをアクティブにする
これでファイル名フィールドに記述されているファイルがハイライト表示される
もしそのリスト内にそのファイルがない場合は、なにもハイライト表示されないので、そのフォルダにあるかを探すときも便利

範囲内のオブジェクトのみ選択する方法

Bで矩形選択したり、Cで選択したりすると、その範囲に触れたオブジェクトが選択されてしまう
エッジや頂点を選択する際に、領域の中にすっかり入っているものだけ選択したい場合は、CtrlLMBドラッグで投げ縄選択する
この選択方法だと、投げ縄の領域にすっかり入っているオブジェクトが選択される
ただし、投げ縄領域内にすっかり入るオブジェクトがない場合は、その領域に触れたオブジェクトが選択される
この特性を使い分けながら選択すると便利
あとは、どこか一つ選択して、CtrlLMBで選択すると、そこまでの最短ルートを選択してくれるのも絡めるといいかも
それを複数箇所やるときは、最初の選択はShiftで追加選択し、CtrlLMBの時はShiftしなくてもそれまでの選択が解除されることはない

シーム通りに展開されない場合

UV マッピング用にシームを設定して Unwrap してもそれぞれのフェースがバラバラに展開される場合は、各フェース毎にそのフェース用の頂点とエッジが存在し、隣り合うフェースと頂点とエッジが共有されていない状態になっている(Wavefront 形式でインポートしたオブジェクトで発生した)
この状態では、もともとフェース同士に関連がないため、設定したシームに関係なくバラバラに展開されてしまう
このようなオブジェクトを設定したシームにそって展開したい場合は、重複した頂点を除去する必要がある
Edite Mode でオブジェクトを選択して Remove Doubles を実行する
これで重複していた頂点とエッジが除去され、隣り合うフェース同士が一致する頂点とエッジで連結され、シームの設定が有効となる
ただし、Remove Doubles によってなめらかに連続していたフェースがカクカクになることがあるので、要注意
シームでコントロールする UV マッピングの必要があるオブジェクトは、Remove Doubles してもカクカクにならない程度にポリゴンを細かくするしかないかな…

展開すると斜め

UV マッピングネタ
スクエアなエリアなのに、展開すると斜めになったりするときがある
たとえば直方体状のもので、上面と底面と側面とに分けたりした時に、上面だけ斜めになったりとか
そんなときは、それを選択して回転してもいいけど、UVs - Pack Islands をやってみよう
Image エリア内にできるだけ無駄なく収めようとしてくれるので、変に斜めになったりしない
全体の向きが気に入らない時は回転しよう

テクスチャマッピングネタ

角のない柱状のオブジェクトにグルっと綺麗にプロシージャルテクスチャを付けたい時、上下面はいい感じだけど柱状の側面は伸びちゃったりする場合がある
UV マッピングではアスペクト比を維持できて良いんだけど、切れ目ができてしまうので綺麗にいかない
そんな時は、Texture CoordinateUV -> Mapping -> プロシージャルテクスチャの Vector と接続し、MappingScale で調整しよう
オブジェクトが Z 軸方向に長い場合は、MappingZ Scale を大きく調整するといい感じになる

同じテクスチャスケールにする方法

プロシージャルテクスチャを利用してオブジェクトにシボを表現するマテリアルを作成し、それを複数のオブジェクトに割り当てると、それぞれのオブジェクトの大きさによってテクスチャスケールが変わってしまう
簡単に同じ大きさに統一するには、同じスケールにしたいオブジェクトをジョイントして一つのオブジェクトとしてしまおう


Wiki についてのメモ

アップロード可能なファイルの条件
  • ファイル容量 500k まで
  • ファイル名文字数 50 文字まで



コメントを投稿するには画像の文字を半角数字で入力してください。


画像認証

  • 最終更新:2016-07-28 16:25:09

このWIKIを編集するにはパスワード入力が必要です

認証パスワード